Swirling flow

Cisco PIX Configuration

Below is an example of Cisco's command line configuration for their family of PIX firewalls.

The following Cisco PIX Configuration is only for reference use only and is not intended to be utilised for live PIX configurations. Configuring a PIX or firewall incorrectly can often cause more damage than not having any protection at all. 

Cisco PIX Configuration

interface ethernet1 auto
interface ethernet0 100full
interface ethernet0 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password secret
passwd secret
hostname testcustomer-fw
domain-name testcustomer
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list OUTSIDE permit icmp any any
access-list INSIDE permit ip 192.168.1.0 255.255.255.0 any
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside 62.140.5.185.129 255.255.255.248
ip address inside 192.168.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 213.83.114.131
nat (inside) 1 192.168.1.0 255.255.255.0
access-group OUTSIDE in interface outside
access-group INSIDE in interface inside
route outside 0.0.0.0 0.0.0.0
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
aaa authentication http console LOCAL
aaa authentication telnet console LOCAL
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
console timeout 0
username admin password privilege 15
terminal width 80
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
http server enable
http 192.168.1.0 255.255.255.0 inside